MRB Envelope Generators Do Not Retrigger In Multi Mode

Post Reply
evo2slo
Posts: 8
Joined: Mon Jun 03, 2019 3:20 pm

MRB Envelope Generators Do Not Retrigger In Multi Mode

Post by evo2slo » Thu Oct 08, 2020 4:25 pm

The MRB Velocity Envelope and the envelopes in Modular Voice do not retrigger as expected when the Gate in the VM CV Sources section is changed from Single to Multi.

The expected behavior would be a retriggering of the envelope when a key is held down and then another key pressed when in Multi mode. This is what happens with the Cherry Audio Env Gen.

I would very much prefer to use the MRB Vel Env Gen so if this could be fixed it would be greatly appreciated. It also prevents me from using the MRB Modular Voice module, though I can use the Semi-Modular Voice module instead by using the modulation inputs with a different env gen.

I hope this is a simple fix and my explanation made sense. Thank you!

MRBarton
Posts: 50
Joined: Sat Aug 10, 2019 7:11 pm

Re: MRB Envelope Generators Do Not Retrigger In Multi Mode

Post by MRBarton » Thu Oct 08, 2020 7:39 pm

Thank you for that. I will look into it immediately.

MRBarton
Posts: 50
Joined: Sat Aug 10, 2019 7:11 pm

Re: MRB Envelope Generators Do Not Retrigger In Multi Mode

Post by MRBarton » Fri Oct 09, 2020 2:42 am

I have checked both the Velocity Envelope and Lab Voice and all the envelope generators retrigger as expected. I didn't think it would be possible for them not to retrigger because the GATE signal briefly goes to zero when a new legato key is pressed in MULTI mode. Therefore triggering and retriggering is effectively the same thing. I don't know how your patch may be influencing what you are experiencing (perhaps you have a really long attack time), but I will be glad to help you get it sorted out. You can PM me if you like.

evo2slo
Posts: 8
Joined: Mon Jun 03, 2019 3:20 pm

Re: MRB Envelope Generators Do Not Retrigger In Multi Mode

Post by evo2slo » Fri Oct 09, 2020 4:47 pm

Thanks for looking into it. I sent you a PM with a video detailing the issue.

MRBarton
Posts: 50
Joined: Sat Aug 10, 2019 7:11 pm

Re: MRB Envelope Generators Do Not Retrigger In Multi Mode

Post by MRBarton » Thu Oct 15, 2020 3:23 am

OK, after looking at the behavior and comparing the Velocity Envelope to Cherry's envelope generator, I can see there are differences between the two. First of all, you have stumbled onto a condition where both are victims of the very short gate retrigger signal where the GATE dips very briefly upon initiation of new notes in MULTI mode. It is currently a small fraction of a millisecond. At the fastest release setting, neither env gen is capable of a full reset to zero during this brief interval, although mine is a bit faster. Another difference is that the timing is not the same for similar positions of the controls. Halfway up on mine is much faster than halfway up on CA's, so try increasing the ATTACK.

I am going to point this out to CA to see if they might be willing to increase the retrigger time to solve this problem for both of us.

I hope that is of some help.

Post Reply