VM2.0.15: Custom Categories lost (?)

For discussion of the Voltage Modular synthesis ecosystem.
Post Reply
User avatar
Koshdukai
Posts: 82
Joined: Sat Jan 19, 2019 12:34 am

VM2.0.15: Custom Categories lost (?)

Post by Koshdukai » Wed May 27, 2020 2:36 pm

Koshdukai wrote:
Tue May 26, 2020 7:45 pm
I'll tag along (pun intended) this "thank you" thread to praise the new Tag Editor feature.

I can finally put some of the most used modules on their own Category :)
uh... actually, now I'm not sure if there's a bug on this or I'm not getting the lifespan of these changes we do to the Categories.

After changing the Category to a bunch of modules (mostly MIDI and VST Hosting) to new Categories (you guessed it: MIDI and VST) last night, today (new session) those were lost and I'm back with the default Category classifications on those.

So, are these changes only recorded per VM Preset/Session/Rack (I didn't save any, after doing it) or is there a bug here?

Thanks :)

Cherry Garcia
Site Admin
Posts: 287
Joined: Fri Aug 31, 2018 2:57 am

Re: VM2.0.15: Custom Categories lost (?)

Post by Cherry Garcia » Wed May 27, 2020 8:42 pm

The custom categories in 2.0.15 are stored in the catalog database. It's possible if you deleted your catalog database then the categories would be lost. This could also happen if you logged into a new account.
In the next build due out next week, we will have custom categories and the favorites stored in their own file in the Settings folder...but that's not out quite yet.

User avatar
Koshdukai
Posts: 82
Joined: Sat Jan 19, 2019 12:34 am

Re: VM2.0.15: Custom Categories lost (?)

Post by Koshdukai » Wed May 27, 2020 8:52 pm

Cherry Garcia wrote:
Wed May 27, 2020 8:42 pm
The custom categories in 2.0.15 are stored in the catalog database. It's possible if you deleted your catalog database then the categories would be lost. This could also happen if you logged into a new account.
In the next build due out next week, we will have custom categories and the favorites stored in their own file in the Settings folder...but that's not out quite yet.
Thank you for all this information!

Well, I didn't (willingly at least) deleted my catalog database (how do I even do that?** :D) nor do I have any other CA account, so I'm a bit at a loss now with this one :? but I'm glad to know that there's a new update next week with an improvement on this.

Will wait for it before doing any more (re)Category(zation) :)


**ah, is it the Settings\General\Delete Module Files ?! Never used this one.
...will the module updates do that as well? I think there were some updates after I made the custom Categories.

Cherry Garcia
Site Admin
Posts: 287
Joined: Fri Aug 31, 2018 2:57 am

Re: VM2.0.15: Custom Categories lost (?)

Post by Cherry Garcia » Wed May 27, 2020 10:20 pm

Regardless, this will not be an issue with the next build. (=

Post Reply