Search found 115 matches

by AndyMac
Tue Feb 26, 2019 9:29 am
Forum: Voltage Modular
Topic: Enable formatting and embedded URLs in module Info... display
Replies: 0
Views: 1248

Enable formatting and embedded URLs in module Info... display

It would be really helpful for the Info... display for a module to honour the formatting and links in the description on the store, or if not able to honour the formatting at least to hide this when the description text from the store is displayed within the application. See e.g. PSP Audio and my ow...
by AndyMac
Tue Feb 26, 2019 9:10 am
Forum: Module Designer
Topic: Debugging issues that happen when presets loaded
Replies: 3
Views: 467

Re: Debugging issues that happen when presets loaded

As I was getting ready to reply to this, I realized that there's an important difference between the VM and the module designer: in Voltage Modular, the module won't get calls to ProcessSample until all initialization has taken place, but in the module designer, you can get ProcessSample calls befo...
by AndyMac
Tue Feb 26, 2019 9:05 am
Forum: Module Designer
Topic: Debugging issues that happen when presets loaded
Replies: 3
Views: 467

Re: Debugging issues that happen when presets loaded

That's really useful background - and good to understand the differences in behaviour in the current tools, and that you are looking to get this more consistent. Anyway, from this, I don't have to worry about getting current values during Initialise phase (which I had been doing) as long as they are...
by AndyMac
Tue Feb 26, 2019 7:22 am
Forum: Module Designer
Topic: Logarithmic Sliders/Knobs
Replies: 6
Views: 737

Re: Logarithmic Sliders/Knobs

Great, and sounds a really flexible implementation. Now I need to work out whether I can migrate my custom code to this (as the custom skew point sounds ideal for my uses) in a way that can maintain existing stored settings/presets for existing users. So, to make it possible to do automatic migratio...
by AndyMac
Mon Feb 25, 2019 8:57 pm
Forum: Module Designer
Topic: Including presets with a module/bundle
Replies: 3
Views: 437

Re: Including presets with a module/bundle

Thanks - I though that there must be a way :-)
by AndyMac
Mon Feb 25, 2019 8:56 pm
Forum: Module Designer
Topic: Bug with Skin Editor?
Replies: 2
Views: 394

Re: Bug with Skin Editor?

Found a workaround - opened the .skin and .skinproject files and replaced the 37 width and height with 25, as the 25px versions of the in-the-box ones are. Would be nice to have option in the skin editor to fix the size of the sockets without having to go into the files directly.
by AndyMac
Mon Feb 25, 2019 8:21 am
Forum: Module Designer
Topic: Feature Request for Manufacturers Settings Page for Store
Replies: 4
Views: 612

Feature Request for Manufacturers Settings Page for Store

It would be useful to have the ability to add a description (formatted, with links) to the manufacturers page in addition to the links, etc. that are already available.
by AndyMac
Sun Feb 24, 2019 4:15 pm
Forum: Module Designer
Topic: Including presets with a module/bundle
Replies: 3
Views: 437

Including presets with a module/bundle

Is there an easy way to include presets (which I am using to provide some hints/tips on the use of modules) with a module or, specifically in my case, a bundle? It would be really useful to be able to automatically add these in a specific manufacturers category to the existing presets, and to mainta...
by AndyMac
Sun Feb 24, 2019 3:45 pm
Forum: Preset Exchange
Topic: Tutorial/Examples Presets for Andrew Macaulay's module collections
Replies: 4
Views: 1741

Tutorial/Examples Presets for Andrew Macaulay's module collections

Following a request for some tutorials/examples on how the various modules in my collections can be used, and what they can be used for, I have put together some simple (and not musically great) example presets with notes included (using "blank" modules). I intend to expand this over time, or when r...
by AndyMac
Sun Feb 24, 2019 3:28 pm
Forum: Cherry Audio Store
Topic: Bug on payment screen (when used with Edge)
Replies: 6
Views: 1667

Bug on payment screen (when used with Edge)

There seems to be a bug on the payment screen (at least for Microsoft Edge users) following the change of payment processor.
{85660195-92D9-456E-B33D-ED78B750140A}.png.jpg
{85660195-92D9-456E-B33D-ED78B750140A}.png.jpg (74.05 KiB) Viewed 1667 times