Search found 20 matches

by CherryRuss
Mon May 20, 2019 9:52 am
Forum: Module Designer
Topic: VMD compilations hang
Replies: 2
Views: 36

Re: VMD compilations hang

Hi Gary. When you have the chance, please send us a log file from a session when the compile fails to finish. If you click the "Open Log Files Folder" in the Preferences dialog (on the 'Miscellaneous' page), it'll show you the folder where the file gets created; it'll be called ModuleDesigner.log. T...
by CherryRuss
Tue May 14, 2019 5:58 am
Forum: Module Designer
Topic: Delete Module?
Replies: 2
Views: 59

Re: Delete Module?

Hi Jack. I assume you mean you want to delete a module you've published from your list of modules so it doesn't show up in Voltage anymore? You can do that from the website, like so: 1) Go to cherryaudio.com and log in to your account 2) Click on the "Your Account" link in the page footer 3) Click o...
by CherryRuss
Mon May 13, 2019 7:50 am
Forum: Module Designer
Topic: No 'Publish"
Replies: 5
Views: 87

Re: No 'Publish"

Hi Jack. The 'publish' option should be disabled if you're currently compiling/building or if you're running the debugger or the "run without debugger" option. If none of those are the case, possibly the module designer has gotten confused about its current state; try reloading the project. If it's ...
by CherryRuss
Mon Apr 22, 2019 8:06 am
Forum: Module Designer
Topic: 1.3.11 Debugging Issue?
Replies: 6
Views: 199

Re: 1.3.11 Debugging Issue?

Hi Terry. Thanks for the update. Your log files indicate that the java machine fails to initialize in the debug client, and we suspect it's due to the debugger from the previous instance failing to release its TCP socket, but we're not sure. We're probably going to have to add yet more logging to he...
by CherryRuss
Mon Apr 15, 2019 6:50 am
Forum: Module Designer
Topic: 1.3.11 Debugging Issue?
Replies: 6
Views: 199

Re: 1.3.11 Debugging Issue?

Hi Terry. Sorry you're having this problem. Is it happening with both the "Debug" and "Run without Debugger" options or with just one of them? When you have the chance, please get the module designer into this state and then send us your log files. If you go to the "Miscellaneous" page of the prefer...
by CherryRuss
Thu Apr 04, 2019 8:24 pm
Forum: Module Designer
Topic: Way to force redraw/refresh of module GUI/elements
Replies: 2
Views: 185

Re: Way to force redraw/refresh of module GUI/elements

It's actually a bug that SetMidpointValue wasn't causing the knob to get redrawn. We've fixed this for the next build. Last week's build had a few issues we had to fix, so we're making new builds again this week, and if all goes well, it should be out sometime next week along with the preset-loading...
by CherryRuss
Thu Mar 28, 2019 8:43 pm
Forum: Module Designer
Topic: Radio buttons not redrawing
Replies: 4
Views: 181

Re: Radio buttons not redrawing

Hi Gary. I suspect this may indeed be related to calling a GUI function from the audio-processing thread, largely because of the delay introduced by calling native functions, of which VoltageButton.SetValue is one. Instead of calling button.SetValue directly from ProcessSample, try just storing the ...
by CherryRuss
Fri Mar 22, 2019 12:26 am
Forum: Module Designer
Topic: SetStateInformation not firing when no custom info in preset
Replies: 4
Views: 155

Re: SetStateInformation not firing when no custom info in preset

Yes, it should be in the next build. Possibly out next week, depending on how testing goes.
by CherryRuss
Fri Mar 22, 2019 12:25 am
Forum: Module Designer
Topic: Disabling tips in MD code editor
Replies: 2
Views: 119

Re: Disabling tips in MD code editor

Hi Benard.

We've added preferences for this for the next build.
by CherryRuss
Thu Mar 21, 2019 12:39 am
Forum: Module Designer
Topic: SetStateInformation not firing when no custom info in preset
Replies: 4
Views: 155

Re: SetStateInformation not firing when no custom info in preset

Hi AndyMac. We've talked this over and decided to send notifications when preset loading begins and ends. Then you can set a boolean flag when preset loading starts and another when SetStateInformation gets called, and if you start getting knob values during the loading process without the SetState ...